KB203: Your device always shows a question mark in the status column when you have transmitted to your Display Player using TCP

Symptom

After you transmit scheduled content to a player, you see a question mark in the status column of Display Director's devices page.

Cause

Scheduled content has been transmitted to a Display Player but the question mark persists. This is because the local time on the Display Player computer is behind the local time on the Display Director computer. When Display Director asks Display Player for acknowledgement-of-receipt of scheduled content, Display Player reports the scheduled content arrived before the Display Director had sent it.

Solution

You need to ensure that the local time is correct on the Display Player computer and that the Display Player computer and Display Director computer are chronologically synchronized.

  1. To set the local time on your Display Player computer:
    Set the computer clock manually using the local Windows Control Panel.
    Note: The clock on a computer is powered by a battery on the motherboard. Any battery is eventually exhausted. A battery low in power operates the internal clock at a slower rate. Replace the battery if you are unsure of it's age.
  2. To chronologically synchronize the Display Player computer with the Display Director computer:
    Clock synchronization between computers can be performed by any one of the following:
    • use Microsoft Windows time server
    • use Microsoft Windows domain controller
    • use a third party tool