KB282: When SQLLink 4.04.5424 (or lower) starts you are informed that you need a license file

Summary

SQLLink 4 is an application with two parts; the system service and the user interface application. When SQLLink 4.04.5424 (or lower) starts, the system service component initializes and the first thing it does is look for a valid license (LIC) file in the installation directory on its computer. Occasionally, the LIC file cannot be found or accessed.

Symptom

If the LIC file cannot be accessed, SQLLink presents a message in the start-up splash screen.

Cause

There are various configurations that can prevent SQLLink from accessing the LIC file.

The most common are:

  1. There is no LIC file in the SQLLink 4 installation directory.
  2. The software trial period is over and your LIC file has expired.
  3. You received a LIC file from Omnivex and your E-mail client formatted it incorrectly when it was saved.
  4. The LIC file is corrupted and contains erroneous data.
  5. You have multiple LIC files in the SQLLink 4 directory. Only the first LIC file is read and it is invalid. LIC files are ordered alphabetically.
  6. The user account under which the the SQLLink 4 Service runs, does not have sufficient permissions to access the LIC file in the SQLLInk installation directory; possibly influenced by domain policies affecting permissions.
  7. The User Account Control (UAC) settings are restricting access to the SQLLink 4 directory.
  8. The FIPS (Federal Information Processing Standard) compliance requirement registry setting is enabled on the computer's operating system and this interferes with attempts to read the licencse file.

Solution

For any of the following causes:

  1. There is no LIC file in the SQLLink 4 installation directory.
  2. The software trial period is over and your LIC file has expired.
  3. You received a LIC file from Omnivex and your E-mail client formatted it incorrectly when it was saved.
  4. The LIC file is corrupted and contains erroneous data.

Then:

  • Contact Omnivex Registration: registration@omnivex.com.
  • Alternatively, you can use the SQLLink 4 Reg application to generate the E-mail. This application launches automatically when you start the SQLLink user interface application and your LIC file cannot be read. You can also manually start SqlLinkReg.exe from its location in your SQLLink installation directory.
  • The E-mail sent to you by our Registration Team contains the LIC file installation instructions.

If the cause is:

  1. that you have multiple LIC files in the SQLLink 4 directory. Only the first LIC file is read and it is invalid. LIC files are ordered alphabetically.
    then the solution is: Delete all of the LIC files in your SQLLink installation directory except for the most recent one.
  2. that the user account under which the the SQLLink 4 Service runs, does not have sufficient permissions to access the LIC file in the SQLLInk installation directory; possibly influenced by domain policies affecting permissions.
    then the solution is: Configure the user account to have sufficient permissions to access and read the SQLLink installation directory.
  3. that the User Account Control (UAC) settings are restricting access to the SQLLink 4 directory.
    then the solution is: Configure UAC to a lower setting so it does not interfere with SQLLink's operation.
  4. that the FIPS (Federal Information Processing Standard) compliance requirement registry setting is enabled on the computer's operating system and this interferes with attempts to read the licencse file. This applies to versions of SQLLink prior to version 4.03.4528.2
    then the solution is: Upgrade to SQLLink version 4.03.4528.2 or higher.