KB343: SQLLink service exception due to faulting module ntdll.dll
Symptom
SQLLink repeatedly crashes. After observing the Event Viewer logs, the faulty module is reported as ntdll.dll
SQLLink repeatedly crashes. After observing the Event Viewer logs, the faulty module is reported as ntdll.dll
Symptom
You are getting unexplained exceptions and experiencing increased memory usage when using Microsoft's ODBC drivers to connect to your third party database.
Cause
Microsoft's ODBC drivers leak memory over a long period of time.
Solution
When setting up your ODBC data source, use your database vendor's latest ODBC driver rather than the one provided with Windows.
Summary
A new license file is required when upgrading to SQLLink 4 (versions 4.04.5424 or lower) from a version earlier than 4.02.4044.1.
Symptom
When starting an upgraded version of SQLLink 4 for the first time, the splash screen appears with a message requesting that a new license file needs to be obtained from Omnivex.
This message does not mean that the existing license agreement with Omnivex is invalid, but that the new version of SQLLink 4, coupled with the particular system configuration, requires a reissue of the license file.
Summary
SQLLink 4 is an application with two parts; the system service and the user interface application. When SQLLink 4.04.5424 (or lower) starts, the system service component initializes and the first thing it does is look for a valid license (LIC) file in the installation directory on its computer. Occasionally, the LIC file cannot be found or accessed.
Symptom
If the LIC file cannot be accessed, SQLLink presents a message in the start-up splash screen.