KB157: You can’t start the Moxie Player or Studio applications because the local Moxie Agent service won’t start

Symptom

When you start your Moxie Studio, it appears to be unregistered and you cannot connect to the Omnivex Moxie Data Server.

When you manually try to start the Omnivex Moxie Data Server service or the Omnivex Moxie Agent service from the Services window, you see an error message.

Cause

Your services can't start because the Windows Event Log is full and not allowing your service to write new events to it.

Solution

You can set your Windows Event Viewer to overwrite the oldest events in the event log when newer events arrive.

To change your Windows Event Viewer settings:

  1. Open the system Control Panels dialog.
  2. Double-click Administrative Tools. The Administrative Tools dialog appears.
  3. Double-click Event Viewer. The Event Viewer dialog appears.

  4. Select Application.

  5. Click Action > Properties. The Application Properties dialog box appears.

  6. Select Overwrite events as needed.
  7. Click OK.
  8. From the Administrative Tools window, double-click Services. The Services window appears.

  9. Select Omnivex Moxie Data Server.
  10. Click Start the service. Both your Omnivex Moxie Data Server and Omnivex Moxie Agent services start.
  11. Start Moxie Studio.

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