KB343: SQLLink service exception due to faulting module ntdll.dll
Symptom
SQLLink repeatedly crashes. After observing the Event Viewer logs, the faulty module is reported as ntdll.dll
SQLLink repeatedly crashes. After observing the Event Viewer logs, the faulty module is reported as ntdll.dll
Your antivirus software flags OmnivexEventLog.dll as a threat.
This is a false positive. The file included with Moxie 7.03 R3 and earlier can be flagged as a potential threat because the DLL is unsigned. (Moxie 7.04 and higher already includes the signed version.)
Replace the DLL file with a signed version:
Summary
Omnivex legacy products are considered feature complete and will not receive additional functionality. In most cases these products have been replaced by other products; customers with annual maintenance and support (AMS) can migrate to the new product based on their existing license. Omnivex supports these products under our AMS program. Listed below is the most recent version of each Omnivex legacy product and their supported operating systems. The information below is subject to change. This article is regularly updated.
Step-by-step instructions to help you install your Omnivex software. This is the standard installation process for all of our software, except:
Version Update to address reported resource allocation problem
A problem was identified where memory requirements for the SQLLink Service would steadily increase over time. This issue has been addressed and no other changes have been made in this version.
September 30, 2013
Symptom
You are getting unexplained exceptions and experiencing increased memory usage when using Microsoft's ODBC drivers to connect to your third party database.
Cause
Microsoft's ODBC drivers leak memory over a long period of time.
Solution
When setting up your ODBC data source, use your database vendor's latest ODBC driver rather than the one provided with Windows.
Summary
SQLLink 3 supports any ODBC-supported database. In order for SQLLink to be able to read the data returned from your ODBC database, it must be formatted in plain text.
SQLLink 4 supports any Oracle, Microsoft SQL Server or ODBC-supported database.
Symptom
You have removed your secondary monitor or changed your desktop layout using the Windows Display Properties and now some of your Omnivex program windows or dialog boxes no longer appear. It may appear as though your Omnivex program has frozen after clicking a button or menu option but the program is actually waiting for an off screen dialog to be closed.
Cause
Summary
Typically Omnivex applications use TCP/IP for communications. The following table describes the TCP/IP port used by each Omnivex application unless you specify a different port number to be used. If you are running the applications on a single computer, typically no additional configurations are necessary.
Summary
The AMS program includes technical support that provides the resources to solve specific product issues. Omnivex Technical Support hours are 8:00AM to 6:00PM EDT.
The AMS program covers questions and troubleshooting of unexpected behavior related to documented features.
Technical support does not include: