KB340: Moxie Players display "No licensed Player connections remain at the Moxie Data Server."

Symptom

Moxie Players display a "No licensed Player connections remain at the Moxie Data Server. Check with your Moxie Administrators to ensure that connection are available" message. Either:

  1. Some Moxie Players display this message OR
  2. All Moxie Players display this message

Cause

Depending on your symptom (a or b), either:

  1. You have reached the maximum number of Players that are allowed to connect to the Data Server.
  2. The Omnivex Moxie Data Server service was started or restarted, either:

    1. with no license file present in the installation folder or
    2. when the license file was locked in an unreadable state

Solution

Depending on your symptom (a or b), either:

  1. Delete some Players from the Data Server (using the System Manager module), or purchase additional Moxie Players and update the Data Server license.
  2. The Moxie Data Server must be licensed through one of the two methods listed below.

Note: Method 1 should be attempted first; if the Moxie Data Server is unable to connect to the Omnivex licensing server, then use Method 2.

Method 1: 

  1. Navigate to the Moxie installation directory, by default:

    • C:\Program Files\Omnivex\Moxie for 64-bit installations
    • C:\Program Files (x86)\Omnivex\Moxie for 32-bit installations
  2. Open Tools.
  3. Run Omnivex Data Server Connection.exe.
  4. Accept the licensing agreement and click Next.
  5. Supply the Data Server connection information and click Connect.
  6. Once the connection is established, click Next.
  7. Supply the licensing information and click Next.

Method 2:

  1. Contact registration@omnivex.com and request a License.LIC file.
  2. Stop the Omnivex Moxie Data Server service.
  3. Copy the License.lic file in the Moxie installation directory.
  4. directory, by default:

    • C:\Program Files\Omnivex\Moxie for 64-bit installations
    • C:\Program Files (x86)\Omnivex\Moxie for 32-bit installations
  5. Start the Omnivex Moxie Data Server Service.

Note: If Moxie has been upgraded from a 32-bit to a 64-bit version, the Moxie installation directory remains C:\Program Files (x86)\Omnivex\Moxie.

Prevention

If you need to update the license of your Moxie Data Server, launch Moxie Studio, open the Studio Options and click on the Connections tab. From here, click Licensing.

Note: Ensure the license file is not locked (e.g. from permissions or anivirus software). If the file is locked when Data Server service restarts, this problem can occur.

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